root/branches/debug/debian/rules

Revision 128, 2.0 KB (checked in by anton, 3 years ago)

Debugging branch added

  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10#export DH_VERBOSE=1
11
12
13
14
15CFLAGS = -Wall -g
16
17ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18        CFLAGS += -O0
19else
20        CFLAGS += -O2
21endif
22
23# shared library versions, option 1
24version=2.0.5
25major=2
26# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
27#version=`ls src/.libs/lib*.so.* | \
28# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
29#major=`ls src/.libs/lib*.so.* | \
30# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
31
32configure: configure-stamp
33configure-stamp:
34        dh_testdir
35        # Add here commands to configure the package.
36        cmake .
37
38        touch configure-stamp
39
40
41build: build-stamp
42build-stamp: configure-stamp
43        dh_testdir
44
45        # Add here commands to compile the package.
46        $(MAKE)
47
48        touch $@
49
50clean:
51        dh_testdir
52        dh_testroot
53        rm -f build-stamp configure-stamp
54
55        # Add here commands to clean up after the build process.
56        -$(MAKE) clean
57
58        dh_clean
59
60install: build
61        dh_testdir
62        dh_testroot
63        dh_clean -k
64        dh_installdirs
65
66        # Add here commands to install the package into debian/tmp
67        $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
68
69
70# Build architecture-independent files here.
71binary-indep: build install
72# We have nothing to do by default.
73
74# Build architecture-dependent files here.
75binary-arch: build install
76        dh_testdir
77        dh_testroot
78        dh_installchangelogs
79        dh_installdocs
80        dh_installexamples
81        dh_install --list-missing
82        dh_installman
83        dh_link
84        dh_strip
85        dh_compress
86        dh_fixperms
87        dh_installdeb
88        dh_shlibdeps
89        dh_gencontrol
90        dh_md5sums
91        dh_builddeb
92
93binary: binary-indep binary-arch
94.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the browser.